查看: 2880|回复: 16

[版本发布] ShareSDK 简洁版更新说明(v3.3.0)

[复制链接]

Rank: 5Rank: 5

主题:
帖子:
积分:
0

[版本发布] ShareSDK 简洁版更新说明(v3.3.0)

[复制链接]
2880 16 | 发表于 2016-5-18 11:26:02 |阅读模式 | |
本帖最后由 Donel Chan 于 2016-5-18 18:30 编辑

此次更新如下:
1.新增QQ定制分享内容接口,支持在分享音频/视频时设置播放按钮
2.修复Google+在iPad分享是界面的分屏适配问题。并新增分享界面的横竖屏可控接口
3.更新微信SDK,为最新的支持IPv6的版本
4.更新新浪微博SDK,为最新的支持IPv6的版本
5.修复少数发生率极低的BUG

以下用户建议更新:
1.需要在分享QQ音频/视频 时设置播放按钮的用户
2.需要使用Google+分享,并且应用支持iPad或者需要控制Google+分享界面横竖屏的用户
3.使用了并需要更新微信SDK的用户(支持IPv6,并修复部分Bug如bundleid前后缀为com时引发崩溃)
4.使用了并需要更新新浪微博SDK的用户(支持IPv6)

特别说明:最近苹果AppStore政策进行调整,要求所有iOS应用必须支持IPv6。ShareSDK本身无论是旧版还是新版都一直支持IPv6。本次更新同时会将ShareSDK所包含的微博、微信SDK进行更新。其中需要注意的是,在使用新版微信SDK,微博SDK的过程中,测试到在Xcode7.2 里, 在开启bitcode的情况下 进行应用的打包(Archive)会报错。而在Xcode7.3不开启bitcode的情况下则能正常打包,希望广大开发者注意这一点。

以下是详细说明:
1.增加一个新的定制QQ分享内容的接口,其中新增参数audioFlashURL、videoFlashURL 用于支持分享音频/视频 设置播放按钮,如下图:

img1

img1

在项目中调用如下图所示:

img2.png

2.新增Google+分享界面的横竖屏控制。可用于控制在进行Google+分享时,分享界面的横竖屏控制。接口如图

img3google.png

3.更新微信SDK为最新版本,支持IPv6。新版微信SDK修复了以往存在的一些Bug,例如在Bundle Identifier 填写如 "com.xxx.com" 的格式的时候会引发崩溃的问题。
注意:如有使用最新版本微信SDK,在开启bitcode的情况下,使用xcode 7.2进行打包(Archive)会报错。解决方法是使用Xcode7.3 进行打包,或者不使用bitcode。

4.更新新浪微博SDK为最新版本,支持IPv6。
注意:如有使用最新版本微博SDK,在开启bitcode的情况下,使用xcode 7.2进行打包(Archive)会报错。解决方法是使用Xcode7.3 进行打包,或者不使用bitcode。

Rank: 5Rank: 5

主题:
帖子:
积分:
0
 楼主| 发表于 2016-5-18 18:30:55 |
顶一个!

Rank: 1

主题:
帖子:
积分:
0
发表于 2016-5-19 15:38:41 |
顶楼上。

Rank: 1

主题:
帖子:
积分:
0
发表于 2016-5-19 15:46:52


报错 提示:

No architectures to compile for (ONLY_ACTIVE_ARCH=YES, active arch=x86_64, VALID_ARCHS=i386).


Rank: 1

主题:
帖子:
积分:
0
发表于 2016-5-19 15:47:50 |
报错
No architectures to compile for (ONLY_ACTIVE_ARCH=YES, active arch=x86_64, VALID_ARCHS=i386).

Rank: 5Rank: 5

主题:
帖子:
积分:
0
发表于 2016-5-19 15:53:11 |
您好 您加一下我们的Q:4006852216 把具体的错误信息截图给我们看一下

Rank: 1

主题:
帖子:
积分:
0
发表于 2016-5-27 11:45:52
给力! 顶楼主!!!

Rank: 1

主题:
帖子:
积分:
0
发表于 2016-5-28 09:56:47 |
JackSun 发表于 2016-5-19 15:53
您好 您加一下我们的Q:4006852216 把具体的错误信息截图给我们看一下

qq错了啊 能不能给个正确的号  我这里导入新的sdk报错

Rank: 1

主题:
帖子:
积分:
0
发表于 2016-5-28 11:21:40 |
我们之前是用cocoaPods 集成的 ,能用cocoaPods升级吗? 怎么写,麻烦回复一下

Rank: 5Rank: 5

主题:
帖子:
积分:
0
发表于 2016-5-30 11:09:18 |
杨磊 发表于 2016-5-28 09:56
qq错了啊 能不能给个正确的号  我这里导入新的sdk报错

QQ号没有错,就是4006852216,您不要用mac版QQ,搜不到的估计,换其他电脑吧
12下一页
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

技术支持
免费咨询 | 24小时在线
快速回复 返回顶部 返回列表